python安装pip

由于Linux系统自带python2和pyon2的pip 所有需自行安装python3的pip ,如果使用Linux系统默认的pip下载 会配置到python2的环境 ,所有需要自行安装python3 的pip。
安装过程还是毕竟麻烦的。
1.首先cd 到python3.7的文件夹
2. 下载get-pip wget https://bootstrap.pypa.io/get-pip.py
ll查看:

3.然后用python执行此文件:
python3 get-pip.py
此过程会出现两个错误
错误1 :zipimport.ZipImportError: can’t decompress data
解决:yum -y install zlib*
重新 make make install

错误2:ModuleNotFoundError: No module named ‘_ctypes’
原因:3.7版本需要一个新的包libffi-devel,安装此包之后再次进行编译安装即可。
yum install libffi-devel -y
make
make install

然后再python3 get-pip.py 出现成功字样表示安装pip成功 路径在/usr/local/python3/bin下:

4.查看pip版本:
最后建立pip3的软链接 和自带的pip区分开
配置
至此 在Linux系统中 配置python3.7环境 就基本上ok了

如果发现下载不了或者地址失效,请联系客服QQ: 2323178881
找资料 » python安装pip

提供最优质的资源集合

立即查看 了解详情